Blog API outage due to database issues
Incident Report for Twingly
Resolved
All of our systems has been up and running for a while again, and the backlog has been worked through. The Blog Data collection has now returned to normal levels.

The issue were caused by a minor database update, which contained an unexpected change that wasn't compatible with the client version we were using in our projects. The solution was to upgrade the database client in our projects to a newer version.

We're sorry for the inconvenience caused by this downtime, and we will change our routines to ensure this doesn't happen again.
Posted Aug 19, 2022 - 16:56 CEST
Monitoring
Our Blog Data collection services are being started again, and new data is now being delivered through the Blog Search API and Blog LiveFeed API again.

It will take some time before we have worked through the backlog, so we'll update the status again once the queues in our system are empty.
Posted Aug 19, 2022 - 15:11 CEST
Identified
We have identified the issue and the APIs are now working again, though they contain no new data. We are working on getting the Blog Data collection system up and running again as soon as possible.
Posted Aug 19, 2022 - 13:26 CEST
Investigating
We are having problems with our main database used for storing blog data, which is causing downtime for our Blog APIs. We are currently investigating the issue.
Posted Aug 19, 2022 - 10:30 CEST
This incident affected: Blog Search API v3, Blog LiveFeed API v5, and Blog Data collection.