Low Blog API insert volume due to database issues
Incident Report for Twingly
Resolved
The blog data collection has been up to speed for a few days now, and everything still looks good. We do not expect any data to have been lost because of the database problems, only delayed.
Posted Feb 07, 2025 - 10:08 CET
Monitoring
During the weekend, parts of our blog data collection system were down, causing the insert volumes to be lower. The issues were caused by problems with our main storage, which also resulted in some posts inserted into the Blog LiveFeed API getting the wrong timestamp.

Right now everything is up again, however, some LiveFeed customers may have missed some data due to these problems.

If you think that you have gotten lower number of blog posts during the weekend, you can jump back to the timestamp "2025-01-03T00:09:30Z" in the Blog LiveFeed API, which is when the problems were corrected.
By going back to an older timestamp in your Blog LiveFeed, you should be able to recover the missing data that was inserted with the wrong timestamp/timezone. See the "timestamp" parameter in the Blog LiveFeed API documentation at https://app.twingly.com/blogs?tab=livefeed_documentation#request-parameters.

We're sorry for the inconvenience this has caused, and we will continue to monitor the situation.
Posted Feb 03, 2025 - 11:29 CET
This incident affected: Blog Search API v3, Blog LiveFeed API v5, and Blog Data collection.